re = /(?<=\d)\s*(?=(?:st|nd|rd|th)\b)/
str = 'foo 1 st, 2 nd, 33 rdfgs,33 rd,bar 134 th'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result