use strict;
my $str = 'foo 1 st, 2 nd, 33 rdfgs,33 rd,bar 134 th';
my $regex = qr/(?<=\d)\s*(?=(?:st|nd|rd|th)\b)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";