$re = '/(?<=\d)\s*(?=(?:st|nd|rd|th)\b)/';
$str = 'foo 1 st, 2 nd, 33 rdfgs,33 rd,bar 134 th';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;