import Foundation
let pattern = #"(?<=\d)\s*(?=(?:st|nd|rd|th)\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"foo 1 st, 2 nd, 33 rdfgs,33 rd,bar 134 th"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)