import re
regex = re.compile(r"(?<=\d)\s*(?=(?:st|nd|rd|th)\b)")
test_str = "foo 1 st, 2 nd, 33 rdfgs,33 rd,bar 134 th"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)