# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/com\\/\Kshop(\\/.*?)\.htm/product\1\//gm;t' <<< "http://www.website.com/shop/ford-truck-hitch-extension.htm"