import Foundation
let pattern = #"com\/\Kshop(\/.*?)\.htm"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"http://www.website.com/shop/ford-truck-hitch-extension.htm"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"product\1/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)