using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"com\/\Kshop(\/.*?)\.htm";
string substitution = @"product\1/";
string input = @"http://www.website.com/shop/ford-truck-hitch-extension.htm";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}