re = /com\/\Kshop(\/.*?)\.htm/m
str = 'http://www.website.com/shop/ford-truck-hitch-extension.htm'
subst = 'product\\1/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result