const regex = /com\/\Kshop(\/.*?)\.htm/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('com\\\/\\Kshop(\\\/.*?)\\.htm', 'gm')
const str = `http://www.website.com/shop/ford-truck-hitch-extension.htm`;
const subst = `product\1/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);