#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)com\/\Kshop(\/.*?)\.htm"
Local $sString = "http://www.website.com/shop/ford-truck-hitch-extension.htm"
Local $sSubst = "product\1/"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)