use strict;
my $str = 'http://www.website.com/shop/ford-truck-hitch-extension.htm';
my $regex = qr/com\/\Kshop(\/.*?)\.htm/mp;
my $subst = 'product\\1/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";