$re = '/com\/\Kshop(\/.*?)\.htm/m';
$str = 'http://www.website.com/shop/ford-truck-hitch-extension.htm';
$subst = "product\1/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;