import re
regex = re.compile(r"com\/\Kshop(\/.*?)\.htm", flags=re.MULTILINE)
test_str = "http://www.website.com/shop/ford-truck-hitch-extension.htm"
subst = "product\\1/"
result = regex.sub(subst, test_str)
if result:
print(result)