using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\+|00)?\d{1,3})?[1-9][0-9]{9}$";
string input = @"+449807093606
00449807093606
is valid in my regex pattern,
wanted to make valid for
+446707093606
446707093606
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}