import re
regex = re.compile(r"^((\+|00)?\d{1,3})?[1-9][0-9]{9}$", flags=re.MULTILINE)
test_str = ("+449807093606\n"
"00449807093606\n"
" is valid in my regex pattern, \n"
"wanted to make valid for \n"
"+446707093606\n"
"446707093606\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")