import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\+|00)?\\d{1,3})?[1-9][0-9]{9}$";
final String string = "+449807093606\n"
+ "00449807093606\n"
+ " is valid in my regex pattern, \n"
+ "wanted to make valid for \n"
+ "+446707093606\n"
+ "446707093606\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}