$re = '/^((\+|00)?\d{1,3})?[1-9][0-9]{9}$/m';
$str = '+449807093606
00449807093606
is valid in my regex pattern,
wanted to make valid for
+446707093606
446707093606
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);