package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\+|00)?\d{1,3})?[1-9][0-9]{9}$`)
var str = `+449807093606
00449807093606
is valid in my regex pattern,
wanted to make valid for
+446707093606
446707093606
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}