// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((\+|00)?\d{1,3})?[1-9][0-9]{9}$").unwrap();
let string = "+449807093606
00449807093606
is valid in my regex pattern,
wanted to make valid for
+446707093606
446707093606
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}