const regex = /^((\+|00)?\d{1,3})?[1-9][0-9]{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\+|00)?\\d{1,3})?[1-9][0-9]{9}$', 'gm')
const str = `+449807093606
00449807093606
is valid in my regex pattern,
wanted to make valid for
+446707093606
446707093606
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}