# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(RCPT\s+TO:\s*<.*>.*)\s+NOTIFY=\S+(.*)/$1 NOTIFY=NEVER$2/;t' <<< "RCPT TO: <myemail@gmail.com> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=myemail@example.com"