$re = '/^(RCPT\s+TO:\s*<.*>.*)\s+NOTIFY=\S+(.*)/';
$str = 'RCPT TO: <myemail@gmail.com> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=myemail@example.com';
$subst = "$1 NOTIFY=NEVER$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;