#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(RCPT\s+TO:\s*<.*>.*)\s+NOTIFY=\S+(.*)"
Local $sString = "RCPT TO: <myemail@gmail.com> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=myemail@example.com"
Local $sSubst = "$1 NOTIFY=NEVER$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)