import Foundation
let pattern = #"^(RCPT\s+TO:\s*<.*>.*)\s+NOTIFY=\S+(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"RCPT TO: <myemail@gmail.com> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=myemail@example.com"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 NOTIFY=NEVER$2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}