package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(RCPT\s+TO:\s*<.*>.*)\s+NOTIFY=\S+(.*)`)
var str = []byte(`RCPT TO: <myemail@gmail.com> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=myemail@example.com`)
var substitution = []byte("$1 NOTIFY=NEVER$2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}