// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(RCPT\s+TO:\s*<.*>.*)\s+NOTIFY=\S+(.*)").unwrap();
let string = "RCPT TO: <myemail@gmail.com> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=myemail@example.com";
let substitution = "$1 NOTIFY=NEVER$2";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}