using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(RCPT\s+TO:\s*<.*>.*)\s+NOTIFY=\S+(.*)";
string substitution = @"$1 NOTIFY=NEVER$2";
string input = @"RCPT TO: <myemail@gmail.com> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=myemail@example.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}