import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(RCPT\\s+TO:\\s*<.*>.*)\\s+NOTIFY=\\S+(.*)";
final String string = "RCPT TO: <myemail@gmail.com> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=myemail@example.com";
final String subst = "$1 NOTIFY=NEVER$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}