const regex = /^(RCPT\s+TO:\s*<.*>.*)\s+NOTIFY=\S+(.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(RCPT\\s+TO:\\s*<.*>.*)\\s+NOTIFY=\\S+(.*)', '')
const str = `RCPT TO: <myemail@gmail.com> NOTIFY=SUCCESS,FAILURE,DELAY ORCPT=myemail@example.com`;
const subst = `$1 NOTIFY=NEVER$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);