# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\S+ ([^,]+), (.+)/$2\\$1/sug;t' <<< "(GMT+07:00) Indian, Christmas"