$re = '/\S+ ([^,]+), (.+)/su';
$str = '(GMT+07:00) Indian, Christmas';
$subst = "$2\\$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;