import re
regex = re.compile(r"\S+ ([^,]+), (.+)", flags=re.DOTALL | re.UNICODE)
test_str = "(GMT+07:00) Indian, Christmas"
subst = "$2\\\\$1"
result = regex.sub(subst, test_str)
if result:
print(result)