use strict;
my $str = '(GMT+07:00) Indian, Christmas';
my $regex = qr/\S+ ([^,]+), (.+)/sup;
my $subst = '$2\\\\$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";