// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?su)\S+ ([^,]+), (.+)").unwrap();
let string = "(GMT+07:00) Indian, Christmas";
let substitution = "$2\\\\$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}