#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "H\d*"
Local $sString = "C40H51N11O19 - 51 hydrogens" & @CRLF & _
"" & @CRLF & _
"C40H789N11O19 - 789 hydrogens" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"C2HO - 1 hydrogen" & @CRLF & _
"HO3 - 1 hydrogen" & @CRLF & _
"" & @CRLF & _
"CO2 - no hydrogens (empty)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")