using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"H\d*";
string input = @"C40H51N11O19 - 51 hydrogens
C40H789N11O19 - 789 hydrogens
C2HO - 1 hydrogen
HO3 - 1 hydrogen
CO2 - no hydrogens (empty)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}