import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "H\\d*";
final String string = "C40H51N11O19 - 51 hydrogens\n\n"
+ "C40H789N11O19 - 789 hydrogens\n\n\n"
+ "C2HO - 1 hydrogen\n"
+ "HO3 - 1 hydrogen\n\n"
+ "CO2 - no hydrogens (empty)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}