re = /H\d*/
str = 'C40H51N11O19 - 51 hydrogens
C40H789N11O19 - 789 hydrogens
C2HO - 1 hydrogen
HO3 - 1 hydrogen
CO2 - no hydrogens (empty)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end