// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"H\d*").unwrap();
let string = "C40H51N11O19 - 51 hydrogens
C40H789N11O19 - 789 hydrogens
C2HO - 1 hydrogen
HO3 - 1 hydrogen
CO2 - no hydrogens (empty)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}