# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\|\s?(?>opening|ending|insert)\s?=.*)([^,\n]+),?\s?/{{track|p=$1}}\n/gm;t' <<< "|opening= MAGIC TIME, Test
| ending = MAGIC TIME, Test, Test2
|insert = MAGIC TIME, Test, Test2"