import Foundation
let pattern = #"(?<=\|\s?(?>opening|ending|insert)\s?=.*)([^,\n]+),?\s?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
|opening= MAGIC TIME, Test
| ending = MAGIC TIME, Test, Test2
|insert = MAGIC TIME, Test, Test2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{{track|p=$1}}\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)