#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\|\s?(?>opening|ending|insert)\s?=.*)([^,\n]+),?\s?"
Local $sString = "|opening= MAGIC TIME, Test" & @CRLF & _
"| ending = MAGIC TIME, Test, Test2" & @CRLF & _
"|insert = MAGIC TIME, Test, Test2"
Local $sSubst = "{{track|p=$1}}\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)