re = /(?<=\|\s?(?>opening|ending|insert)\s?=.*)([^,\n]+),?\s?/m
str = '|opening= MAGIC TIME, Test
| ending = MAGIC TIME, Test, Test2
|insert = MAGIC TIME, Test, Test2'
subst = '{{track|p=$1}}\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result