import re
regex = re.compile(r"(?<=\|\s?(?>opening|ending|insert)\s?=.*)([^,\n]+),?\s?", flags=re.MULTILINE)
test_str = ("|opening= MAGIC TIME, Test\n"
"| ending = MAGIC TIME, Test, Test2\n"
"|insert = MAGIC TIME, Test, Test2")
subst = "{{track|p=$1}}\\n"
result = regex.sub(subst, test_str)
if result:
print(result)