use strict;
my $str = '|opening= MAGIC TIME, Test
| ending = MAGIC TIME, Test, Test2
|insert = MAGIC TIME, Test, Test2';
my $regex = qr/(?<=\|\s?(?>opening|ending|insert)\s?=.*)([^,\n]+),?\s?/mp;
my $subst = '{{track|p=$1}}\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";