using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\|\s?(?>opening|ending|insert)\s?=.*)([^,\n]+),?\s?";
string substitution = @"{{track|p=$1}}\n";
string input = @"|opening= MAGIC TIME, Test
| ending = MAGIC TIME, Test, Test2
|insert = MAGIC TIME, Test, Test2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}