import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\|\\s?(?>opening|ending|insert)\\s?=.*)([^,\\n]+),?\\s?";
final String string = "|opening= MAGIC TIME, Test\n"
+ "| ending = MAGIC TIME, Test, Test2\n"
+ "|insert = MAGIC TIME, Test, Test2";
final String subst = "{{track|p=$1}}\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}