# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'[^\\']*(?:\\.[^\\']*)*'(*SKIP)(*F)|\.(\w+)/[$1]/gms;t' <<< "$app.url = $cfg.url ? $cfg.url : 'domain.ext'"