#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)'[^\\']*(?:\\.[^\\']*)*'(*SKIP)(*F)|\.(\w+)"
Local $sString = "$app.url = $cfg.url ? $cfg.url : 'domain.ext'"
Local $sSubst = "[$1]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)